Service Disruption - Traffic Insights did not render protocol/services data the UI on the AU1 cluster
Incident Report for Auvik Networks Inc.
Postmortem

Service Disruption - Traffic Insights did not render protocol/services data in the UI in the AU1 cluster

Root Cause Analysis

Duration of incident

Discovered: Oct 21, 2024 15:03- UTC
Resolved: Oct 21, 2024 16:15- UTC

Cause

The recent refactoring of Traffic Insight Services inadvertently altered the offset management behavior.

Effect

This caused traffic identification to not render properly in the UI for clients in the AU1 cluster,

Action taken

All times in UTC

10/15/2024

15:01-15:35 Engineering is alerted to an issue involving traffic insight data for clients in the AU1 cluster not rendering correctly. Engineering begins its investigation. It is noted that traffic has not been rendered correctly since October 19 at approximately 10:00.

15:41-15:55 A solution to fix the problem is designed and implemented. Traffic insights data is appropriately rendered in the UI.

16:15 Traffic for data classification is confirmed flowing as it should over in the UI.

Future consideration(s)

  • Timing of changes and a more thorough review process of results will be implemented for any future work performed on the affected services.
Posted Nov 01, 2024 - 10:51 EDT

Resolved
Clients on the AU1 cluster that subscribed to Auvik Performance did not have their Traffic Insights data rendering protocol/services data from approximately 10:00 UTC on October 18 until 14:00 UTC on October 21.
Data rendering is now working as expected.

We apologize for the interruption of services.

An RCA will follow after a complete investigation.
Posted Oct 21, 2024 - 12:51 EDT