TrafficInsights processing delayed in eu2.my
Incident Report for Auvik Networks Inc.
Postmortem

Service Disruption - TrafficInsights data delayed for EU2 cluster

Root Cause Analysis

Duration of incident

Discovered: Nov 15, 2021 - UTC 19:38
Resolved: Nov 15, 2021 - UTC 20:05

Cause

The upgrade of database service hung during the automated process.

Effect

The refreshed TrafficInsights data was delayed for 25 minutes for Auvik Performance clients in the EU2 cluster. There was no data loss and no other services were affected.

Action taken

11/15/2021 All times in UTC

19:38 - UTC Planned and pre-tested zero-downtime upgrade of backend service begins.
19:41 - UTC The service disconnects during the upgrade process.
19:43 - UTC Alerts are registered in Auvik’s monitoring.
19:58 - UTC Auvik engineering team begins investigation.
20:03 - UTC The automated upgrade completes, reconnecting the disconnected service with the platform.
20:05 - UTC Errors for the incident cease.

Future consideration(s)

Auvik will review it’s testing processes and procedures to validate accuracy and completeness for zero-downtime upgrades as compared to actual production implementation.

Posted Nov 24, 2021 - 14:27 EST

Resolved
TrafficInsights processing was delayed in eu2.my from 19:40 UTC to 20:05 UTC, and users may have seen errors in the TrafficInsights dashboard. The system has recovered, is operating normally, and data is up to date.
Posted Nov 15, 2021 - 15:00 EST